blogbot/default.nix
2025-01-11 20:22:47 -07:00

9 lines
222 B
Nix

{ pkgs ? import <nixpkgs> {},
bash,
deno,
}: let
src = ./.;
in pkgs.writeScriptBin "blogbot" ''
#!${bash}/bin/bash
${deno}/bin/deno --allow-net --allow-read --allow-write --lock ${src}/deno.lock ${src}/mod.ts
''